Rotating Object After Its Pivot Point Was Moved

About Truespace Archives

These pages are a copy of the official truespace forums prior to their removal somewhere around 2011.

They are retained here for archive purposes only.

Rotating Object After Its Pivot Point Was Moved // Bugs

1  |  

Post by Electric Jim // Sep 14, 2008, 8:01am

Electric Jim
Total Posts: 98
I'm getting odd animation playback behavior, and I think it's because I'm using an object for which I repositioned the pivot point before doing any of the keyframing. Perhaps someone could verify the same behavior? Here are the details:

I wanted to keyframe some "plain old" rotation for my object, but I wanted the rotation to look "off-center". So before starting any of the keyframing, I moved the object's pivot point away from its original location (which appeared to be more-or-less at the object's geometrical center).

After moving the pivot point, I started setting up my animation normally: I added my base track and recorded a single keyframe for it at Frame 0. Then I added a second track (with Additive Blend mode enabled but Pass Through disabled), and recorded its unchanged "reference" keyframe at Frame 0. Then I recorded four rotation keyframes in this track by numerically entering new Z-axis Rotation values directly. (To be specific: For each new keyframe I first jumped to the desired frame. Then I clicked in the Z-Axis Roation field in the panel stack, typed "+ 90" after whatever value was already there, and presed <Enter>. Then I pressed the "Set Keyframe" button.) The resulting Z-axis rotation values were set up to give a single full rotation, as follows:

Frame 0 (Reference): -180 degrees (or 180 degrees, if you prefer)

Frame 8: -90 degrees

Frame 16: 0 degrees

Frame 24: 90 degrees

Frame 32: -180 degrees (or 180 degrees) - same as Frame 0

Everything looks fine if I jump from keyframe to keyframe, but upon scrubbing or playback I find that my object moves between the keyframes as well as rotating, rather than just rotating in place around its (off-center) pivot point. When I examine the FCurve data, I find that the translation curves are not flat as they should be, indicating that, indeed, unwanted positional changes were keyframed in addition to the desired rotational changes. I'll try flattening out the translation FCurves and seeing whether I'm left with just my desired rotation, but I really believe that this should not be necessary. I should not be seeing translational keyframes being recorded in this scenario.

I'm guessing this is all due to my having moved the object's pivot point before recording any animation, because I know I've recorded pure rotations in the past without introducing unwanted translational keyframes.

EDIT: Well, going in and flattening the translation FCurves actually made matters worse. Could someone explain what I'm missing? Thanks.

Post by Emma // Sep 14, 2008, 8:12am

Total Posts: 344
Didn't retry what you wrote, but generally moving the pivvot worked fine for me. I used it for all animations of me where you see the butterfly. No bones used ther, pivot is moved to the lower end of the wing.

This didn't work in pre 7.6 version if I remember right, there the pivot "jumped" away.

Whenever I have such effects of "jumping" I almost every time find some keyframe that was recorded before I do the final render. So therefore meanwhile I examine if there are any ones wrong and delete them.

Post by Electric Jim // Sep 14, 2008, 8:36am

Electric Jim
Total Posts: 98
Thanks for reponding.

As an experiment I went through the same process with a simple geometrical object -- a basic cube -- and everything worked fine, whether or not I "pre-moved" the pivot point. So I guess it's not the pivot point after all. It must be something about the object itself, which seems to exhibit the weird behavior I described no matter how many times I start over from scratch with the animating.

The object I'm using is a bit of a mish-mash, consisting of a head modelled in another application and imported to tS, with tS hair added, and a few other sibling objects connected, one of which also has some tS hair added. Perhaps something about this history is introducing some sublety I don't understand, or confusing tS in some way. Maybe if I reduce the structure down to a single geometrical model -- with Booleans unions and so forth -- whatever wierdness is manifesting itself will be ironed out. I guess I'll see...

Thanks again.

Post by Emma // Sep 14, 2008, 8:48am

Total Posts: 344
Ok, in that case I would suggest that you use 4 view while you change the pivot point.

- Reason is that you have a 2D look on your monitor,

- the 4 view gives you a chance to watch the arrows of the pivot from different positions targeting through your "deformed object"

Post by Igor K Handel // Sep 14, 2008, 8:55am

Igor K Handel
Total Posts: 411
As a precaution I suggest flattening history, incase something odd going on there. Even if it fails to sort it at least thats another variable out of the way.


Post by brotherx // Sep 15, 2008, 1:40am

Total Posts: 538
I was trying to do some procedural stuff and the object, which was a booleaned object, flattened, was spinning about some random point rather than its centre. I'm not sure if it is the same thing but it might be.

I had to go to model, reset something and then go back to workspace but I forget what...posted it in tech forums.

And it worked find with simple objects. There is definitely an issue there...

Post by Electric Jim // Sep 15, 2008, 6:19am

Electric Jim
Total Posts: 98
Thanks again for the responses, guys. :)

BrotherX: I think I've found your previous thread. (It's dated 08/06/08 and titled "Procedural Animation question", about your rotating torus, right?) When I get the opportunity to play with my scene again I'll try resetting the axes on Model-side, and see whether that helps at all. (I sure hope it does, because the last thing I found yesterday before I turned off the computer in frustration was that attempting to Boolean the various parts together screws up (i.e., eliminates) the textures when I go to Model-side to render it all. So it appears I need to leave things just grouped together, rather than actually Boolean'ed together, in order to keep my textures.)

Post by brotherx // Sep 15, 2008, 6:38am

Total Posts: 538
yup. That's the one. I realised afterwards I could have just used the standard cylinder to do what i needed by shelling it and then setting the thickness accordingly and then I wouldn't have had the problems I did...

Post by Electric Jim // Sep 22, 2008, 2:08am

Electric Jim
Total Posts: 98
I finally found the time to get back to this project. Going to Model side and re-centering then re-positioning the pivot point (axes) there did solve the problem. (Specifically: Now, when I rotate the object in the Workspace, it rotates around the correct pivot point, rather than rotating-plus-moving -- or rotating around some other pivot point.)

The problem definitely appears to be related to manipulating the pivot point of a compound object in Workspace. If I get the time at some point, I'll try seeing whether I can recreate the problem with a simpler compound test object than the one I'm currently using, to make it repeatable. (Because I certainly want to get this issue fixed.)

Thanks again for everyone's help. :) is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2022. All Rights Reserved.   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn