Vray question

About Truespace Archives

These pages are a copy of the official truespace forums prior to their removal somewhere around 2011.

They are retained here for archive purposes only.

Vray question // Tech Forum

1  |  

Post by Isaac // Oct 25, 2008, 9:22am

Total Posts: 17
What are the steps to include Vray [installed & loaded] automatically from launch (of tS7.6)

~So far, every time I run tS... Vray needs to be found, installed [with the PM] and manually loaded ~what a pain eh?
(worth it for the results... but there must be a way right?)

Post by Emma // Oct 25, 2008, 11:39am

Total Posts: 344
Hmmm, this is wondering me, I

- installed VRay in same directory as truespace

- with Install manager did "Install new" and then Load

since then VRay is always immediately active when I start the program

Post by Isaac // Oct 25, 2008, 2:17pm

Total Posts: 17
That tells me that that is at least how its supposed to work... Vray renders just fine, but needs loading with each run. :confused:

Post by mrbones // Oct 25, 2008, 2:40pm

Total Posts: 1280
loading in drop down menu?

That tells me that that is at least how its supposed to work... Vray renders just fine, but needs loading with each run. :confused:

Post by Isaac // Oct 26, 2008, 4:01am

Total Posts: 17
loading in drop down menu?

No... Loading via the PM; Every run of tS7.6 starts seemingly without Vray installed or loaded (its not listed in the PM, and gives the "no offline renderer" warning if you try to use it).


In this case, it listed the "Vray photo renderer, 4" but won't use it, and pops up the message, "no offline renderer installed", until I add Vray through the PM ~again.

~But curiously... When installed, its listed as "Vray photo renderer, 1" (or ",2" or ",3")


Post by Johny // Oct 26, 2008, 5:33am

Total Posts: 672
Hi Isaac, try this:

1. Open PM then uninstall Vray from your tS7.6
2. press "Ctrl+Shift+R" for reset your tS7.6
3. close your tS7.6
4. run tS7.6
5. open PM (question 1: can you see Vray on PM list?)
6. if not found vray on pm list, install and load it.
7. close your tS7.6
8. run tS7.6 again
9. everything run well now?

Post by Isaac // Oct 26, 2008, 11:30am

Total Posts: 17
Thanks Johny,

When I run truespace, the PM does not list Vray. When I right click on the Vray render button, the "panel" panel, lists "Vray photo renderer, 5" in the drop down menu. [see screen shots in my earlier post].

Ctrl+shift+R clears it all as expected, and tS restarts with default layouts.

The offline renderer list is cleared.

Installing Vray, loading, and shutting down trueSpace then restarting it, has "Vray photo renderer" [without the instance number] listed in the render list...

but... Clicking on the render icons still gives the "no offline renderer installed" error, and Vray is still not listed in the PM; but I can again install and load it as usual, and then it works... and shows up in the list as "Vray photo renderer, 1"

~btw.. even if it said 5 instead of 1, there would only be one renderer listed.

Post by trueBlue // Oct 26, 2008, 1:06pm

Total Posts: 1761
If you open the Scene View and within the Offline renderers, you should only have one Vray photo renderer. (without #'s)
You can right click the Vray photo renderer in the Scene View and select Browse in LE. You can then delete all of the duplicated Vray photo renderer nodes.
Just a guess but I suspect that you are not cleaning out you last installment folders. It is recommended that you install to clean directory and not overwrite them. When you uninstall tS7.6 and Vray, explore the remaining folders for anything you want to keep and move them somewhere else. Then delete All of the Folders before reinstalling tS7.6 and Vray.

Post by Johny // Oct 26, 2008, 5:13pm

Total Posts: 672
Ok Isaac, now try this:
1. open PM for uninstall Vray from tS7.6
2. close tS7.6
3. Uninstall Vray from your computer
4. restart computer
5. install VRay to your tS.76 folder
6. run tS7.6
7. open Pm for install and load Vray
8. click render button.
9. close vray render view window
10. press 'CRtl+Shift+R'
11. clic render button (question2: is it rendered succesfull or you got error msg that said not offline rendered installed?)

If you got error result on above step number 11, please compress all 'log' file on your <trueSpace76/tS> folder into a zip file for more examination. together with your PM window scene capture.

Are you on XP or Vista?
If your OS is VISTA, please make sure you run as aministrator or install your tS7.6 not on drive C: (try to install it on d:\trueSpace76 as example)

do you remember used to answer something like not allow TS7.6 to change register from you system defence/antivirus or similar program? (if yes maybe your antivirus/system defence software remember it and always prevent the command-> then you need to reinstall tS7.6 on other folder and answers yes for same question from defence software question)

If still not working, you really need to post you log file and PM scene capture on zip file here.

Post by Isaac // Oct 28, 2008, 8:10pm

Total Posts: 17
I'll collect the logs, and post when I have time after the 31st...

For now... tS will have to wait.

Thanks again
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2021. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn