Widget on Model Side

About Truespace Archives

These pages are a copy of the official truespace forums prior to their removal somewhere around 2011.

They are retained here for archive purposes only.

Widget on Model Side // Rants and Raves

1  |  

Post by jrboddie // Oct 10, 2008, 8:15am

jrboddie
Total Posts: 91
pic
Why does the widget on the model side sometimes switch from navigate to move object or even navigate in a toolbar?


I find the behavior bizarre and unpredictable.


I have not found anything in the manual to explain this 'feature'.

Post by TomG // Oct 12, 2008, 4:11am

TomG
Total Posts: 3397
Not sure what you mean, could you give us more information? Navigation and moving the object are actually different widgets (the navigate one is large and in the bottom right, the move object appears next to the object, and they can never change functionality). Do note there is also the magic ring on the Model side when you first create a primitive, which is a third kind of widget. These widgets cannot swap functionality though. It is possible for the object widget and the navigation widget to occupy the same space on occasion, but you can still see there are two widgets (just you might not be able to click on the one you intend).


I have no idea what "navigate in a toolbar" might means at all :) Changes the highlighted icon? Moves the toolbar around on the screen?


Perhaps some screen shots would help along with some extra description of what you find is happening?


HTH!

Tom

Post by jrboddie // Oct 12, 2008, 5:04am

jrboddie
Total Posts: 91
pic
I found out that the problem related to the navigation widget moving the selected object was due to my mis-clicking the widget and actually click-dragging the area outside. In the model side, this causes the selected object to move (a behavior which is different from the Workspace side, thank goodness.)


Regarding the drawpanel issue, sometimes the drawpanel was not oriented on the screen as I would like and I tried to use the navigation widget to reposition my view. Frequently, my view did not change but I could see in the area occupied by the pop-up tool bar associated with the drawpanel that the buttons and background were scrolling around as I controlled the navigation widget. It was as if the tool bar was its own selected window in which the nav widget was controlling.


If I see it again, I will try and take a screen shot. However, I am using the Model side as little a possible. For me, the Workspace is a much better experience.

Post by Electric Jim // Oct 13, 2008, 2:07am

Electric Jim
Total Posts: 98
I found out that the problem related to the navigation widget moving the selected object was due to my mis-clicking the widget and actually click-dragging the area outside. In the model side, this causes the selected object to move (a behavior which is different from the Workspace side, thank goodness.).


This behavior was most likely exhibited because the Move tool was the selected tool at the time. Any clicks-and-drags that are not on a widget are interpreted in terms of the currently selected tool, so if the Move tool is active and you click-and-drag off of a widget, the currently selected object will move.


This behavior is the same in Workspace, so if you have the Move (or Scale or Rotate) tool selected and click-and-drag somewhere other than on a widget, you will see your object move or scale or rotate, as appropriate. (I'm guessing that this behavior did not appear to be exhibited when you checked out Workspace because the Move tool was not selected in WS.) Just something to keep in mind.

Post by jrboddie // Oct 13, 2008, 4:14am

jrboddie
Total Posts: 91
pic
Thanks. I will watch out for that.
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2021. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn