Texture Auto-Render

About Truespace Archives

These pages are a copy of the official truespace forums prior to their removal somewhere around 2011.

They are retained here for archive purposes only.

Texture Auto-Render // TS6 and Older

1  |  

Post by transient // Nov 3, 2008, 5:11pm

transient
Total Posts: 977
pic
In 6.6 when I apply a material to an object it automatically renders the object. Is there any way to turn this off?:confused:

Post by spacekdet // Nov 3, 2008, 7:15pm

spacekdet
Total Posts: 1360
pic
Stab the Escape key.
-or-
Switching to 'Draw Objects As Solid' rather than a more wireframe-y mode will halt the autorender. Depending on the texture complexity, size, and your vid card there may instead be a slight delay while the realtime dislay updates.

No way to turn it on or off explicitly that I know of other than the above.

<EDIT> You can also try different settings in the 'Detail' box in Display Options.

Post by transient // Nov 3, 2008, 7:39pm

transient
Total Posts: 977
pic
A very annoying feature this one, especially when using shder-lab as the renders tend to be a bit sluggish. As a workaround I made a tiny perspective view and activate it while I'm testing textures. It renders quick, so no need to bash my keyboard.


Thanks for the help. :)

Post by trueBlue // Nov 3, 2008, 8:21pm

trueBlue
Total Posts: 1761
pic
Does Toggle Use of Textures in Solid Render help?

Post by transient // Nov 3, 2008, 8:29pm

transient
Total Posts: 977
pic
Yes, as long as the viewport is in anything other than wireframe mode. Thanks for the tip, this was bugging me.:)

Post by Emmanuel // Nov 4, 2008, 3:16am

Emmanuel
Total Posts: 439
pic
In 6.6 when I apply a material to an object it automatically renders the object. Is there any way to turn this off?:confused:


In OpenGL display mode, wireframe objects don't automatically render as you paint them.

That trick doesn't help much though with V-Ray because tS freezes at painting (time for V-Ray to "render" the object, even if it is not visible on screen).

Post by transient // Nov 4, 2008, 3:43am

transient
Total Posts: 977
pic
Unfortunately, d3d works better for 6.6 on my system, although that's nice to know.:)
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2021. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn