TS5 area lights

About Truespace Archives

These pages are a copy of the official truespace forums prior to their removal somewhere around 2011.

They are retained here for archive purposes only.

TS5 area lights // TS6 and Older

1  |  

Post by Nez // Oct 9, 2006, 4:18am

Nez
Total Posts: 1102
pic
This may have been answered a long time ago but I can't find an answer using a search of the current forums - does anyone know why area lights don't appear to work properly in TS5? They cast their light OK but they're supposed to be visible in the render - and they aren't... I can't find anywhere in the settings to change this, although I may be missing something.

I'm sure they worked alright in version 4.3! Anyone know anything about this?

Thanks :o

Post by GraySho // Oct 9, 2006, 6:07am

GraySho
Total Posts: 695
pic
If it's the same as in 6.6, check "render geometry", which means render the gemoetry that represents the area light in the realtime preview.

Post by Bobbins // Oct 9, 2006, 6:22am

Bobbins
Total Posts: 506
I think I'm right in saying that area lights are single sided, so they only appear in the final render if the light emitting side is visible too. You can't see the 'back' of an area light.

Post by Nez // Oct 9, 2006, 6:44am

Nez
Total Posts: 1102
pic
I have checked which side of the light I'm looking at but it still doesn't work. According to the manual (and as happened in v4.3) you didn't need any geometry to represent the light, it should just be visible - it was the only form of lighting to generate a visble light with no geometry. As far as I recall (am going ot have to go back and check) it worked fine in 4.3 but doesn't appear to work in 5.1 - I think it's a bug but just trying to confirm whether this is the case and whether any fix was produced...

The light works in as much as it still illuminates, it's just not a visible light source (i.e it's the same in that respect as all the other light sources - but it's SUPPOSED to be visible!)

Hope that makes sense.

Post by TomG // Oct 9, 2006, 7:22am

TomG
Total Posts: 3397
This DOES sound familiar. I believe it was a tS5.1 issue resolved in tS5.2. But it was a long time ago and I could well be wrong on that. Still, gives you something to investigate (upgrading to tS5.2 :) ) - and maybe it will jog someone else's memory on reading this!


A search of the old forums (the archive link) might turn up some more info about it.


Thanks!

Tom
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2022. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn