Animating camera movement

About Truespace Archives

These pages are a copy of the official truespace forums prior to their removal somewhere around 2011.

They are retained here for archive purposes only.

Animating camera movement // New Users

1  |  

Post by jrboddie // Apr 28, 2009, 12:15am

jrboddie
Total Posts: 91
pic
I am trying to animate some simple camera movements. I can do this in camera view, setting keyframes and navigating through the viewport. However I thought it would be easier to do this from a top down view. That is, move the camera, set keyframe, repeat. The problem is the camera does not have a widget for movement. So I encapsulated the camera and find that the animation behaves strangely. This behavior is not limited to the camera so there must be something I am doing wrong.


Here is the scenario:


1. From a top down view, create a cube object. Elongate it so it has a 'direction'.

2. Set key frame

3. Advance frame marker, move cube to new location and set key.

4. Advance frame marker, rotate cube and set key.


Run the animation and the object moves linearly to a location then rotates as expected.


Now erase or disable the track created above and encapsulate the cube. Repeat steps 2-4 above on the encapsulated object. When I run the animation this time, the object moves wildly about.


Can someone please explain what I need to do to make an object that is an encapsulation animate in an orderly way?

Post by TomG // Apr 28, 2009, 1:24am

TomG
Total Posts: 3397
Encaps the cube with what - a camera specifically, or anything? Did you use Encaps in 3D and not just Encaps on its own? Could there have been a "trace" of the animation left before doing the encaps (meaning the encapsulate was applied to an object that was already animated in some way)?


I am not seeing this behavior here, could you give more info (a video in this case would be good).


Note I tried the following:


1. Make cube, animate cube; undo; make second cube, encaps, animate group. All normal


2. Make cube, animate cube, delete track, add second cube, animate group, all normal


3. Make cube, add camera, encaps, animate group, all normal.


4. Make cube, animate cube, encaps with camera without removing animation, all normal (cube moves, camera does not), animate group, all normal (group animation adds on top of cube animation).


HTH!

Tom


As a note, I wasnt in top down view but orthagonal. I've animated a camera from above, I just use hotkeys rather than a widget (Z to move the camera, X to rotate the camera, then just click off the camera object to be able to translate or rotate it), in case that lets you avoid the encapsulation.

Post by Jack Edwards // Apr 28, 2009, 3:10am

Jack Edwards
Total Posts: 4062
pic
You may want to check the pivot location for both the group and the object.

Make sure you keyframe all three rotation axis at the same time since you may get odd rotation if you keyfame individual axis at different keyframes.

Be aware of gimbal lock as well. trueSpace uses a Euler rotation system for animating rotation so gimbal lock can give you very odd animation in something that would seem to be simple. Often two keyframes is not enough for trueSpace to determine the correct rotation direction, so always use at least three keyframes for a rotation.

Post by jrboddie // Apr 28, 2009, 5:04am

jrboddie
Total Posts: 91
pic
Thanks, Tom and Jack!

With your input, I think I have resolved the issue. It was associated with animating the rotation operation of an object that is a 3D encapsulation of a single primitive (cube or camera).

In order to get a rotation without translation, it was necessary to bring up the axis tool for the object, then nomalize the orientation. This must have made the pivot point the same as it would have been for the primitive even though there is no visible change in the position of the axis tool.

Here is a video of what I was seeing:

http://www.youtube.com/watch?v=70aosyP2XE4

Blue block is just a rotated primitive. The red one is encapsulated. The animation is for a simple rotation with no translation.

Post by TomG // Apr 28, 2009, 5:39am

TomG
Total Posts: 3397
Ahh 3D Encaps with nothing but itself. That can be problematic, there was another thread someplace where someone had modeling issues, and it was due to a single object being encapsulated with itself (in that case it was just regular encaps and not 3D encaps).


Glad you got it resolved, I thought you were 3D encapsulating the camera with a cube in order to animate it using widgets (which does work fine, and you can just make the cube invisible in the end).


HTH!

Tom
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2021. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn