Dual Monitor Maximize Problem

About Truespace Archives

These pages are a copy of the official truespace forums prior to their removal somewhere around 2011.

They are retained here for archive purposes only.

Dual Monitor Maximize Problem // Tech Forum

1  |  

Post by jambun11 // Jan 26, 2009, 9:52am

jambun11
Total Posts: 3
I have a Dell Precision 650 with a NVIDIA GeForce 7600 GS installed. I have two Iiyama FS connected to it, one AS4612UT @ 1280x1024 and a PLH540 @ 1600x1200. They are configured as independent screens with the AS4612UT as the primary display. When I maximize the trueSpace desktop on the AS4612UT it fills the screen as it should but when I maximize the desktop on the PLH540 it overshoots the right and bottom edges (see attachment). If I set both displays to 1280x1024 the maximize functions correctly. No other application on this machine behaves this.


Thanks

Post by splinters // Jan 26, 2009, 10:08am

splinters
Total Posts: 4148
pic
Are both monitors running at their native resolution?

A 20" widescreen usually runs at 1680x1050 while a 4:3 screen would be in the 1280x1024 format.

I would presume from your resolutions that these are not widescreen though...:confused:

Post by TomG // Jan 26, 2009, 10:52am

TomG
Total Posts: 3397
I use "mismatched" dualies too, but don't see this problem - I can maximize tS on my 1650 x 1080, or on 1600 x 1200 and it works ok. It also correctly maximizes separate tS windows on each monitor too (eg throwing an LE window on to one monitor, and the main tS app on the other).


I can't think of a possible fix to this, since not ran into it before - I can only think of ensuring the tS app is contained on one monitor before hitting the maximize, in case any part sticking onto the other monitor causes a problem. Also try testing with tS on the monitor that works, and a separate LE window on the one that doesnt maximize properly - does the LE window work then? Or does it show the same problem as when the main app is on there?


Sorry I don't have an immediate solution to hand.


Tom

Post by jambun11 // Jan 27, 2009, 10:16am

jambun11
Total Posts: 3
Hi chapps,

Both screens are running native and I have made sure that all the window is contained on one screen before maximizing. I have also tried it with secondary windows and they to behave the same.


I must say its not a problem, I just don't use the maximize button, I just thought it would be wise to air my findings.


Do you know what language TS is written in, Iconize, Minimize and Maximize are usualy performed with a Windows API call but if TS is written for portability it may do its own functionality.


Thanks.

Post by jambun11 // Jan 28, 2009, 9:26am

jambun11
Total Posts: 3
Hi Again,


I have notice something else. With TS active on the PLH540 1600 x 1200 screen, if I maximize the 3D pane monterily while it is zooming out to full size it shows the image that is on the AS4612UT 1280 x 1024 screen then once it is maximize it repaints the correct 3D image. This seems to indicate that TS is not awear of which screen it is on.
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2021. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn