Couple Questions about Cool Powers4 Plug-ins

About Truespace Archives

These pages are a copy of the official truespace forums prior to their removal somewhere around 2011.

They are retained here for archive purposes only.

Couple Questions about Cool Powers4 Plug-ins // Tech Forum

1  |  

Post by Jimmer // Jan 14, 2009, 3:28am

Jimmer
Total Posts: 30
Ok, I'm using tS6.6 with Cool Powers 4 Plug-ins. I can not seem to get

the "Glow" post process shader to work right. How can I get an individual

object to GLOW. If I set the material id to "0" everything in the scene glows.

If I set it to 1,2,3 ect.... No glow. Does anyone remember how this works?

I dont quite understand the instructions... Duhhhhhh


Also, the post process "Fog" effect does not seem to work quite right.

No matter how FAR AWAY I set the fog "NEAR" distance everything gets fogged. Was there a problem with Cool Powers 4 and Ts6.6????

Post by kena // Jan 14, 2009, 4:27am

kena
Total Posts: 2321
pic
not sure about the cool powers. I never used it. but for fog, the "near" is how far away you want the fog to start showing and the "far" is what sets the density. or was that an earlier version of TS?

Post by TomG // Jan 14, 2009, 5:22am

TomG
Total Posts: 3397
Been ages since I used Coolpowers, but as I remember you had to paint the objects that were supposed to glow with a special shader. Then you had to tell the post process routine that that was the shader you wanted to glow. Maybe the shader had an "id" number built into it someplace.


As I say, memory could be faulty, as it's been many many years since I used it!


Is the fog the native tS post-process fog? Or a Coolpowers fog?


HTH!

Tom

Post by Jimmer // Jan 15, 2009, 3:54am

Jimmer
Total Posts: 30
Thanks for the replies. AS far as the glow effect I figured it (stumbled across) how to do it. Tom you were right..... I found a new color shader that appeared. It works fine..

As far as the fog its the Cool Powers fog effect. I think maybe the distance parameters are off compared to my tS6.6. I can not get the close up (where the fog just starts)

to move further back. Everything is in fog..... Still trying ... This stuff does work though.......
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2021. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn