No shortcuts in PE mode

About Truespace Archives

These pages are a copy of the official truespace forums prior to their removal somewhere around 2011.

They are retained here for archive purposes only.

No shortcuts in PE mode // Tech Forum

1  |  

Post by splinters // Jul 24, 2008, 1:44pm

splinters
Total Posts: 4148
pic
Well, I am sad to say that workspace use for me just got harder. Unless I am missing some hidden settings, my keyboard shortcuts are not available when in PE mode.


It might sound trivial but i am used to changing my view of an object while editing and don't always want to do it in 3D views. I asked some time ago for Space Navigator support which would aleviate this concern somewhat but that is not here yet.


I really need this function if I am going to remain productive in tS/workspace...it is like a sculptor having his tools on a table 6 feet behind him and has to walk backwards and forwards to make amendments...:o


Worst of all, it works just fine in tS7.5...:o


Am I missing something?

Post by Jack Edwards // Jul 24, 2008, 2:17pm

Jack Edwards
Total Posts: 4062
pic
I think that's supposed to be a feature. ;)

If I recall correctly there are separate short cuts for PE mode so that you can have context sensitive short cut keys. In other words the same key can do two different things depending on whether you are in PE mode or Object mode.

Have you tried setting custom short cuts while in PE mode?

Post by stan // Jul 24, 2008, 2:24pm

stan
Total Posts: 1240
pic
Splinters, if I open edit select a face say, then use 'ctrl 6' the view changes is that what you mean? that seems to work for me.:confused:

oh, make sure the 3dwindow is active or it doesn't work..

have they changed the hotkeys values maybe?..look in the
trueSpace76\tS\Scripts\Window.Shortcuts.xml

Post by splinters // Jul 24, 2008, 2:30pm

splinters
Total Posts: 4148
pic
Yup, tried both of these but no go...

I set 1-4 as views just like I normally do in model side. They work fine but as soon as I enter PE mode they stop working.

I tried setting them in PE mode too...:(

No problem doing the same process in tS7.51

Post by TomG // Jul 24, 2008, 2:36pm

TomG
Total Posts: 3397
Yes you can't use those particular hotkeys, not sure why - one little niggle that didnt get sorted. You can hotkey them to other keys though, and use those while in PE mode. Not ideal, but not a showstopper at least. We'll have to see if we can get that resolved though, so that those particular keys can be used.


HTH!

Tom

Post by splinters // Jul 24, 2008, 3:10pm

splinters
Total Posts: 4148
pic
That would be good Tom but for now, the CTRL+1-4 option is working so I can work across both sides.


Cheers

Post by trueBlue // Jul 24, 2008, 10:21pm

trueBlue
Total Posts: 1761
pic
Hey Paul: Looks like you finally got your Isometric View. :)
I got the shortcuts to work in Point Edit mode but I had to edit the Window.Shortcuts.xml file manually to do it.
Edit: Hummm after further testing this seems to break other shortcuts so disregard the above. :(

Post by splinters // Jul 24, 2008, 11:15pm

splinters
Total Posts: 4148
pic
Wow, I never even checked the isometric feature. That really used to bother me...:D
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2020. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn