Thread

can´t get the thing to work (Sdk)

can´t get the thing to work // Sdk

1  |  

c c@c

Sep 10, 1998, 10:56am
I have compiled and tried the Sample Program 1 with Visual C++ v2.0

I get a login error (reason 43). I have tried with 2 different citizen
numbers&passwords, but neither do work.

I am not using "GreeterBot" and "SDK Sample Application #1" as name and
application, just in case...

I have altered the prog just to pass the citizen number and password
directly to AW_LOGIN_OWNER and AW_LOGIN_PRIVILEGE_PASSWORD in the methods,
that is, without the command line parameters (argv[ ]). But it still doesn´t
work.

I wonder if there is any method to see whichare the actual values of the
AW_ATTRIBUTES.

thank you

César

nechtrous

Sep 10, 1998, 3:29pm
I am happy to say I have the greeterBot program running fine. I compiled it
with Visual C++ 5.0. However, I did run across this same problem when trying
to run it for the first time.
Solution: The password it needs is your _privilege_ password, not your
normal password. To specify a privilege password, simply click on Options
menu and then click on Citizen menu item. In that dialog box, you will see
"Privilege Password (optional)" You need to specify a value for this, then
use that password in your command line to the greeterBot program.

Good Luck!

Nechtrous

[View Quote]

roland vilett

Sep 10, 1998, 7:49pm
Yes I've already noticed from the server logs that several people have made
the same mistake: specifying their *login* passwords for the bot instead of
their *privilege* passwords. Bots are designed to acquire their owner's
privileges via the privilege password. They don't want or need their
owner's login password.

Sorry, that's probably not made very clear in the documentation...

-Roland

[View Quote]

1  |  
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2021. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn