Thread

Worldserver(?) bug with global mode + invisible bots (Sdk)

Worldserver(?) bug with global mode + invisible bots // Sdk

1  |  

tony m

Jun 7, 2002, 3:31pm
When an invisible bot exits the world, a Global Mode bot (the mode may
or may not be relevant) will see an exit for the last user who
entered.

Example:

17:05:14 VRT: Shred exits s# 29684 at ?
K9D: - to Tony M - 17:05:14 Shred left
Tony M: goofy xelagots :O
Shred: indeed
Shred: shred left =O

This doesn't happen in just Xelagot. I managed to reproduce it with
another type of bot present (home-made); it took the avatar exit msg
normally and did not recognize my actions until I reentered.

o_O

brant

Jun 8, 2002, 2:48pm
This is a bug in build 39 of the world server - I experienced a similar bug
with bots running in AWTeen that distributed passwords in Global mode and 9
9 9 told me it would be fixed when he got around to upgrading AW's servers
to build 41. Try upgrading to build 41; that should solve the problem.

[View Quote]

jerme

Jun 8, 2002, 8:07pm
Reading this post.. It became a little confusing which build is which.

Does anyone keep track of which builds come out when and the files that go
along with them?

I've never found such a place, so I think I'll dedicate a page on my
website. I'm interested in finding copies of all the aw releases of the AW
browser, admin tool and world server. If you have one of these saved
somewhere, please e-mail it to me with an appropriate description of what it
is.

Thanks,
Jeremy

--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Jeremy Booker
JTech Web Systems
(www.JTechWebSystems.com -- Coming Soon)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[View Quote]

percipient

Jun 9, 2002, 5:28am
Happens to me with a Xelagot on server version 41, in global mode. So-and-so
exits at ?.
Got a whole bunch in a row too, right after the other, yesterday.
--
Percipient

[View Quote]
---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.370 / Virus Database: 205 - Release Date: 6/6/02

percipient

Jun 9, 2002, 5:28am
Oh, and the bot was visible, not invisible.

--
Percipient
[View Quote]
---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.370 / Virus Database: 205 - Release Date: 6/6/02

percipient

Jun 9, 2002, 5:43am
Stupid thing put the messages in the wrong order, opposite of what I sent
them. Heh.

--
Percipient
[View Quote]
---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.370 / Virus Database: 205 - Release Date: 6/6/02

tony m

Jun 13, 2002, 10:07pm
This is with build 41 of the server, Brant.

On 8 Jun 2002 12:48:36 -0400, "brant" <awteen at shoemakervillage.org>
[View Quote] >This is a bug in build 39 of the world server - I experienced a similar bug
>with bots running in AWTeen that distributed passwords in Global mode and 9
>9 9 told me it would be fixed when he got around to upgrading AW's servers
>to build 41. Try upgrading to build 41; that should solve the problem.
>

xelag

Jun 15, 2002, 12:58pm
On 9 Jun 2002 03:43:39 -0400, "percipient"
[View Quote] >Stupid thing put the messages in the wrong order, opposite of what I sent
>them. Heh.

The stupid thing queues up the actions per category, it never sends
directly. As from next version 3.303, the sending order will be:

1) Console messages
2) Whispers
2) Chat Aloud
3) Text


Within each category, messages are sent in the order they were
requested.

Cheers,
Alex

percipient

Jun 17, 2002, 2:26am
Err, sorry. I didn't mean your bot. I was refering to the newsgroup. I
posted two messages and they showed up backwards. Sorted by date, I guess.
One post was an amendment to the other.

--
Percipient
[View Quote]
---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.370 / Virus Database: 205 - Release Date: 6/5/02

kah

Jun 17, 2002, 3:20pm
"percipient" <percipient at percipients.com> wrote in
news:3d0d64dd at server1.Activeworlds.com:

> Err, sorry. I didn't mean your bot. I was refering to the newsgroup. I
> posted two messages and they showed up backwards. Sorted by date, I
> guess. One post was an amendment to the other.

*NOT* the newsgroup, your newsreader did that :-)) The news server doesn't
sort messages (off course, it could, but it wouldn't matter because most
newsreaders sort messages themselfes). Yes, I know I'm freaky for insisting
on this stuff all the time lol ;-))

KAH

1  |  
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2021. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn