runay@cyberjunkie.com (runay) // User Search

runay@cyberjunkie.com (runay) // User Search

1  |  

A way Cool Bot

Mar 6, 1999, 8:08am
What are we waiting for? Let's party! :-D

Runay

On Fri, 05 Mar 1999 08:47:21 -0800 (PST), "Nick Danger"
[View Quote] [View Quote]

HeX

Feb 19, 1999, 6:21pm
Hi,

I just finished porting HeX, an Australian conversation bot by Jason
Hutchens. It should prove to be interesting to say the least if HeX
and Eliza could have a chat some time... ;-)

For now it's in Beta at 1000n 1000w for the next hour or so (till
about 7 VRT).

Runay

HeXbot available for download

Feb 21, 1999, 8:51pm
HeXbot is now available for download at:

http://www.xs4all.nl/~runay/bots.html

HeXbot is an SDK port of HeX, an Australian conversation bot by Jason
Hutchens.

Runay

HeXbot available for download

Feb 22, 1999, 6:22am
Unfortunately, I forgot to add aw.dll. When I get home I'll fix it
right away. The new zip file should be available at about 5 VRT.

Runay

HeXbot available for download

Feb 22, 1999, 11:26am
It contains all the subroutines that allow a C-programmer to write a
bot program for Active Worlds. So without it the program won't work.

But if you're in a hurry you can always download it from
http://www.activeworlds.com/sdk. Just unzip the file and copy aw.dll
to the HeXbot directory.

Runay

[View Quote] >What's it do exactly?
>
[View Quote]

HeXbot available for download

Feb 22, 1999, 4:56pm
Done.

Runay

[View Quote] >Unfortunately, I forgot to add aw.dll. When I get home I'll fix it
>right away. The new zip file should be available at about 5 VRT.
>
>Runay

How?

Feb 24, 1999, 5:57pm
In your Hambot directory there is a file called hambot.ini. At the
bottom of this file there is a line that says UseSDK=0. If you change
the 0 to 1 the bot will be an "SDK bot" and will not be visible as a
user. In the near future the "tourist" bots will be disabled anyway so
all bots will be SDK bots.

Runay

[View Quote] >Occasionally I play around with Hambot but don't really know that much about
>the scripting part. When you use a bot in it's default script it signs on as
>a citizen or tourist in your world and shows up in the worlds list as a
>user. Is there a way to script Hambot to sign on bots as a non user and
>operate in your world but not show up in the list like the ones used in "
>The 13th" or does this require a special kind of bot to do this?
>

Another question

Feb 25, 1999, 1:01pm
Special avatars are 251, 252, 253, 254, 255.
And of course the citnum you are using has to be a PS ;-)

Runay

[View Quote] >Ok, now that I've got this Hambot working again as a SDK bot, anyone know
>how to set it so that it will wear an avatar thats not in the listing? I've
>tried to get it to wear a Special1 but it will so far only be one listed in
>the world avatar.dat file.
>Thanks alot :)
>

I need a C Compiler!!

Nov 10, 1998, 8:18pm
http://www.bloodshed.nu/devc.htm

[View Quote] >If anyone has a good C compiler i NEED IT BAD!!!Email me!
>

I need a C Compiler!!

Nov 15, 1998, 7:54am
Sorry about that. I thought I had it working but was I ever wrong...
Cum to think of it, LCC doesn't work either. It compiles successfully,
even runs successfully without parameters (writes "Usage: ..." to
stdout) but when I enter the username and PP it crashes with some
exception error. So, since I'm not prepared to install a Unix shell on
a Windows95 PC, I guess it's time to end this futile quest and get out
my $90... ;-)

[View Quote] >http://www.bloodshed.nu/devc.htm
>
[View Quote]

aw now closed for bots ?

Nov 12, 1998, 6:30pm
Same problem here. When I use HamBot in SDK mode it never gets past
the WaitFor, it just stops responding. In AW that is, in my own world
it works just fine. HamBot in non-SDK mode still works in both worlds.
Probably just a temporary SDK problem in AW.

Runay

On Thu, 12 Nov 1998 18:55:23 +0100, "Walter Knupe" <wak at faber.ping.de>
[View Quote] >Is it true, that the main world AW is now closed for bots as well ?
>
>its bad that aw_enter does not return giving an error code, and
>its even MORE bad that beta seems the only bot open place now....
>
>bots are not that interesting if you run them in an empty world only...
>
>
>Walter aka Faber
>
>
>

Negative Yaw?

Mar 1, 1999, 7:09pm
Hi,

Don't know what I'm doing wrong but somehow I'm getting a negative
AW_AVATAR_YAW (-1800) when facing south (according to the SDK docs it
should be between 0 and 3599). Any ideas?

Runay

Negative Yaw?

Mar 2, 1999, 5:58pm
Yes I came to the same conclusion after checking some variables.

N = 0
S = -1800
W = 900
E = -900

So, going counterclockwise (left) it goes from 0 to 1799 and clockwise
(right) it goes from -1 to -1800. This means that values on the West
side are OK but values on the East side will yield incorrect results.
Weird, but I guess I can convert this before calling any functions.

Runay

On Tue, 2 Mar 1999 18:35:46 +0100, "Walter Knupe" <wak at faber.ping.de>
[View Quote] >This is a multi-part message in MIME format.
>
>------=_NextPart_000_005B_01BE64DB.7C841940
>Content-Type: text/plain;
> charset="iso-8859-1"
>Content-Transfer-Encoding: quoted-printable
>
>
>Well, i have. When examining it i found that starting from direction 0 =
>it counts up to 1799 when turning clockwise and down to=20
>-1800 when turning counterclockwise.=20
>
>Its not what i expected, but once you know its ok :)
>
>Walter aka Faber
>

Negative Yaw?

Mar 3, 1999, 8:34pm
Thanks all, I finally got it to work. At last I can finish my Holodeck
experiment. Computer, end program ;-)

Runay

[View Quote] >Hi,
>
>Don't know what I'm doing wrong but somehow I'm getting a negative
>AW_AVATAR_YAW (-1800) when facing south (according to the SDK docs it
>should be between 0 and 3599). Any ideas?
>
>Runay

1  |  
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2022. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn